Site Sponsors & Vendors
Results 1 to 4 of 4

Thread: So I have an issue with my G8 09 starting

  1. #1
    Junior Member
    Join Date
    Jan 2021
    Posts
    2
    Post Thanks / Like

    Default So I have an issue with my G8 09 starting

    So I bought my G8 about a week ago from this used dealer ship in Stafford VA. It was fine for the entire week I had it, I drove it from DC to Richmond with no issue. Last night, I was about to head to the gym, I stick the key in the ignition, turn and it does not start. The display and radio turn on but when I turn in an attempt to start it simply made a click sound and would not start. I checked the battery life and its at 82%. After messing with it for an hour, it started and I went to the gym. But now it happened again. I tried starting it via remote start but no dice.

  2. #2
    VIP Member Kermit's Avatar
    Join Date
    Oct 2008
    Location
    Va. Beach, VA
    Posts
    1,941
    Post Thanks / Like

    Default

    Honestly it sounds like a battery issue by you describing a clicking sound. With the cold and all, you might not have enough cracking power. I would try getting it to a auto store to where they can check not only the battery life but also the cold cracking power.
    That's just my off the top of my head.
    2009 G8 GT MGM.
    Performance - 1900 MagnaCharger , Lunati Cam, RCR Ported Heads, Intake and TB, FAST #65 Injectors, CTS-v fuel pump, Kooks 1 3/4" LT and Catted X-Pipe, Pypes Violator Axel-Back, Roto Fab CAI, RX Oil Catch Can, Pedders XA's & Track II Bushings, BMR Sub Frame Connectors, Sway Bars & Rear Control Arms, 19 Inch Staggered (8.5 front/9.5 Rear) VMR 810 Wheels, DBA 4000 Sloted Rotors with Hawk HPS Pads & Russels Brake Lines, Camaro 3.27 Diff, Gforce Axles.
    Cosmetic - Partially De-badged Rear, 6.0L Badges, Tinted Side, Rear Markers & Tail Lights, 35% Tint, Auto-dim Mirror, Spencers 6K 35W & 5K 25W Fog HIDS, Blacked Out Door Chrome, Vagas Nates 3 Gauge Pod W/Interceptor Gauges, Color Matched GXP Diffuser, Shark Fin Antenna, V-LEDs on Side/Rear Markers, Brakes & Back Ups Lights, MM Carbon Fiber Rear Spoiler


    1/4 mile 10.917 at 130.44mph 564 RWHP 568 Torque.

  3. #3
    Junior Member
    Join Date
    Jan 2021
    Posts
    2
    Post Thanks / Like

    Default

    So my coworker, who used to be a mechanic said it was a bad battery. I'm about to get my mechanic to check it out because now the car will not start anymore and the key is stuck. Sucks to suck but I'm gonna have to get it towed. Thanks for your help though.

  4. #4
    Member SpeedDemon G8 GXP's Avatar
    Join Date
    Jan 2021
    Location
    Fort Worth
    Posts
    32
    Post Thanks / Like

    Default

    Quote Originally Posted by Kermit View Post
    Honestly it sounds like a battery issue by you describing a clicking sound. With the cold and all, you might not have enough cracking power. I would try getting it to a auto store to where they can check not only the battery life but also the cold cracking power.
    That's just my off the top of my head.
    I totally agree with Kermit. The clicking gives it away. Just because it says that you have 82% battery life doesn't mean that the battery isn't bad. When you take it to an auto store all they need to do is hook it up to a new battery and see what happen. Now the fact that the key is stuck totally sucks. lol

    2009 Pontiac G8 GXP: Red, manual, LT1-S Twin Disk Monster Clutch, CTS-V 19 inch wheels for that extra grip, cam, exhaust and headers. 451 RWHP 1 of 61

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •