Site Sponsors & Vendors
Page 5 of 5 FirstFirst ... 345
Results 41 to 42 of 42

Thread: Serpentine Belt Installation Help

  1. #41
    Addicted Member JimmyJazz's Avatar
    Join Date
    Sep 2008
    Location
    TX
    Posts
    722
    Post Thanks / Like

    Default

    I developed a chirping a while back. It was the AC tensioner pulley, not one of the main serpentine pulley's.
    '09 Pacific Slate G8 GT,1900 Magnacharger cog drive. Engine rebuilt by Texas Speed and Performance with some very nice parts. Airaid intake, Kooks 1 7/8" lt's, cats, midpipe, SLP PowerFlow exhaust. Pedders lowered touring package. Baer Pro front brakes. ForgeStar F14 GunMetal 19x8.5 Michelin Pilot Sport a/s. '78 El Camino. 2008 model Blue Heeler.

  2. #42
    Junior Member
    Join Date
    Nov 2017
    Location
    IL
    Posts
    22
    Post Thanks / Like

    Default

    I was trying to loop the belt over the tension-er last. That's the hard part because there's a lip on the tension-er which the belt must go OVER before it sits down into the belt grooves on the tension-er. Sooooo.......go ahead and loop it over the tensioner FIRST, and do the WATER PUMP last. This works easier because the water pump doesn't have the lip you must overcome by trying to overpower and over-stretch the belt. You simply slide the belt over/onto the water pump!

    I learned this 'the hard way', and thanks to this forum, I am able to swap belts in a few minutes now, painless!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •