Site Sponsors & Vendors
Results 1 to 6 of 6

Thread: Locked engine ?

  1. #1
    Junior Member
    Join Date
    Oct 2016
    Posts
    5
    Post Thanks / Like

    Default Locked engine ?

    It was running as good as always but suddenly it just turned off while going 30mph down the street... I have no idea what's wrong with but every time I try to start it, it doesn't even turn it just makes a weird clicking sound. Does anyone have any idea what the issue might be ?


  2. #2
    Senior Member RacerxG8's Avatar
    Join Date
    Aug 2008
    Location
    DFW
    Posts
    113
    Post Thanks / Like

    Default

    Dead battery?
    Do the lights dim out when you hit the starter?
    RacerxG8 - Dean P.
    '08 G8 GT Liquid Red
    Full FE3, BMR BK013 kit (removed TOO harsh for DD), Spyder tails, Shark Fin, Volant CAI, and the rest is stock
    Coming soon: GXP front and rear bits

  3. #3
    VIP Member Leon McJones's Avatar
    Join Date
    Apr 2011
    Location
    DFW, TX
    Posts
    131
    Post Thanks / Like

    Default

    Sounds like low battery on the vid. Dying while driving sounds like possible alternator failure. Try jump starting? Any other observations like different fuel, going through high water? Let us know what did you find. Hope its something simple
    09 White Hot G8 GT
    Tuned by Rick Crawford
    Kooks, Circle-D, Vararam, HSRK, BP catch can, RP oil
    DBA 4000, Hawk Ceramic, Russel Stanless, Ate Super Blue,
    FE3, Whiteline, BMR, UMI, Spohn

    Homelink, Adams Premium, Infinity Reference

  4. #4
    VIP Member
    Join Date
    Mar 2009
    Location
    Monroe. OH
    Posts
    3,402
    Post Thanks / Like

    Default

    Dead alternator and then your battery drained. Same thing happened on the beater truck a few weeks ago. Dying while running is the clue.

    Rotohack 102 intake - 102 MAF - TPIS 102 TB - TVS1900 ported & plated w 8 rib 2.5" front + OD rear
    RCR ported heads - RCR Lunati 219/231 113+1 - LSA Crank - Molnar rods - Racetec pistons
    Kooks 1 7/8 LT - Solo 3" CB - 3.27 diff w WaveTrac MT DRs + M&H FRs on Weld RT-S
    CTS-V fuel w Vaporworx - FAST 85s - Alkycontrol meth M15 + M10 - RCR tune
    Old 10.09@138.8 1.51 60'
    New ?@? 716 rwhp 652 rwtq

  5. #5
    Junior Member
    Join Date
    Oct 2016
    Posts
    5
    Post Thanks / Like

    Default Locked engine ?

    Went out to buy a new battery for the car and it still won't turn on, making the same noise as well. Going to check if the engine is locked tomorrow morning... wish me luck


    Sent from my iPhone using Tapatalk
    Last edited by OMGAFG8; 10-06-2016 at 08:49 PM.

  6. #6
    Beyond Help texn884's Avatar
    Join Date
    May 2010
    Location
    Helotes, Texas
    Posts
    4,894
    Post Thanks / Like

    Default

    Any update of what happened to your car??
    2009 Panther Black Metallic "The Black Rat"
    Current Modifications: Front end, Roof Pillars & Front top of roof has Clear Shield, Holden V8 6.0 Badges, Holden V Trunk Badge from Crazy Paul, UPR Catch Can, Corsa Exhaust & Roto Fab CAI. Spare Tire and Jack and Tinted Window's, hood scoops gutted, Poor Mans Heater Hose modification (holding up the hoses with zip ties), Painted the front dart to Panther Black.

    Patrick Guerra's Tune July 12, 2010: 345 HP, 355 Torque on 87 Octane
    Patrick's & Kurt's install of Kooks Long tubes 1 7/8" w/Corsa Connection Pipes
    11-3-10: 362 rwhp, 372 Torque and updated engine and transmission tune.

    New Engine as of 10- 5, 2011. Patrick & Kurt's tune and dyno 10-19 2011:363 rwhp, 365 Torque 93 octane.
    Sounds so GRRRR8 BECAUSE RACE CAR

    7-1-14 Brembo Front Brake upgrade & Bohnam Front Splitter installed Curt here

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •